Commit d0952df1 authored by Jan Kiszka's avatar Jan Kiszka
Browse files

debian: Update to compat level 10, resolve deprecation warnings



This addresses

warning: Compatibility levels before 10 are deprecated (level 9 in use)
warning: -s/--same-arch is deprecated; please use -a/--arch instead
warning: This feature will be removed in compat 12.

on bullseye while remaining compatible with buster.
Signed-off-by: Jan Kiszka's avatarJan Kiszka <jan.kiszka@siemens.com>
parent 7dac93bd
......@@ -102,20 +102,20 @@ binary-indep: build install
# Build architecture-dependent files here.
binary-arch: build install
dh_testdir -s
dh_testroot -s
dh_installinit -s --name=xenomai
dh_installman -s
dh_installdocs -s -A README
dh_link -s
dh_installchangelogs -s
dh_strip -s --exclude=smokey
dh_compress -s
dh_fixperms -s
dh_makeshlibs -s
dh_installdeb -s
dh_shlibdeps -s
dh_gencontrol -s
dh_testdir -a
dh_testroot -a
dh_installinit -a --name=xenomai
dh_installman -a
dh_installdocs -a -A README
dh_link -a
dh_installchangelogs -a
dh_strip -a --exclude=smokey
dh_compress -a
dh_fixperms -a
dh_makeshlibs -a
dh_installdeb -a
dh_shlibdeps -a
dh_gencontrol -a
# Echo config options to control.
echo " ." >> $(CURDIR)/debian/libxenomai1/DEBIAN/control
echo " Compiled with the following options." >> \
......@@ -123,8 +123,8 @@ binary-arch: build install
echo "$(CONFIG_OPTS)" | awk '{ for ( i=1 ; i<=NF ; i++ ) print " "$$i }' >> \
$(CURDIR)/debian/libxenomai1/DEBIAN/control
# End of hackery.
dh_md5sums -s
dh_builddeb -s
dh_md5sums -a
dh_builddeb -a
# We have nothing to do by default.
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment