Skip to content
  • Stefano Babic's avatar
    swupdate: bump to version 7c78773 · 26cc2024
    Stefano Babic authored
    
    
    This includes the following changes:
    
    7c78773 channel_curl: Support for custom headers
    09fd046 channel_curl: Strip newline from received key-unique headers
    413e81f Lua: Improve LuaJIT / Lua 5.1 compatibility
    ee8bf12 scripts: Fix format-overflow compiler warning
    9ed68f2 state: Rename reset_state() to unset_state()
    bcb7c2d cpio header: Add support for newc format
    f8ee098 IPC: Add bounds check for SET_UPDATE_STATE IPC call
    3fb504c doc: handlers: Describe property decompressed-size
    8e6187f handlers: ubivol: add property decompressed-size
    33ed601 encrypted images: Test other key lengths
    907315b doc: encrypted images: Using different key lenghts
    4ea0899 encrypted images: Implement other key lengths in providers
    cfb2917 encrypted images: Accept other AES key lengths
    aed6e94 doc: encrypted images: Add a PKCS#11 section
    1b56d69 doc: Add note on the PKCS#11 libraries
    30f81ef pkcs11: Differentiate key handling based on config
    3bb2c19 Kbuild: Add PKCS11 option
    7d961aa pkcs11: Implement based on wolfSSL and p11-kit
    816cec1 sslapi: Add wolfSSL compatibility macro
    b214f6a mongoose: Hide deprecated function for wolfSSL
    ba8c4a8 Makefile.flags: Add missing wolfSSL definitions
    d2491dd sslapi: Add X509 related wolfSSL definitions
    6f9a761 sslapi: Move CMS-only functions to conditional
    fa1ba52 Rename wolfSSL incompatible definition
    7fe9b4a Kbuild: Add wolfSSL as SSL implementation
    0f03c06 channel_curl: Introduce support for PATCH method
    16e10c4 channel_curl: Make setting channel operation method symmetric
    61d5e28 channel_curl: Rename to channel_callback_ipc()
    372f9c0 channel_curl: Pass through dry_run flag
    daa98b7 suricatta: Adapt to CHANNEL_PARSE_NONE
    0e54840 channel_curl: Make CHANNEL_PARSE_RAW actually "parse"
    c5b7b53 channel_curl: Consolidate effective URL logging
    440f0af channel_curl: get_file: use log function
    330d053 channel_curl: put: use log function, respect nocheckanswer
    3075c60 channel_curl: post: use log & buffer functions, respect nocheckanswer
    795b0ea channel_curl: Factor out channel reply log handling
    5465058 channel_curl: Factor out channel reply buffer handling
    39f0827 channel_curl: Consolidate curl verbose setting
    eede9a3 channel_curl: Make setting request_body symmetric
    e6c98b4 bootloader: remove cruft
    eb1f7d8 rsa_verify_mbedtls: Support RSA PSS
    fa9d27c hawkBit: Fix spelling of hawkBit
    d46655b core: Refactor config file reading to fail early
    9e0bcaa encrypted images: Prevent premature decryption end
    8c43208 doc: Update SWUpdate's understood command line parameters
    5987e62 doc: Fix typo in suricatta's general HTTP server description
    b9cceb8 examples: Update configuration file example
    744def0 encrypted images: fix one block sized image decryption
    a464d8d Make logcolors optional in configuration file
    a5e2e5c diskpart: do not write to disk if partitions do not change
    036e858 Replace WARN with ERROR if save_state fails
    bc47fdd parser: add result of version check in TRACE
    602ab84 doc: encrypted images: Add note on ivt attribute
    347ab28 doc: Mention general HTTP server in suricatta's introduction
    1b68a3b doc: Fix sphinx warning about unterminated bullet list
    5507fec Configure colors for stdout / stderr
    185ec65 lua: BUG in LuaStackDump causes SEGV
    d39dd41 Move artifact version check to inner parsing loop
    7e88bfb diskpart: fix crash in case if GPT
    21136eb Save Update State after each update
    3cd4e82 Make save_state available to coprocesses
    5af74e1 Start network threads before processes
    25ba0a9 Fix progress info message so it can be embedded in a JSON doc
    0297485 doc: extend example for diskpart
    b968508 Fix typo in update status report
    a4f06c3 doc: add ELC 2020 talks with SWUpdate
    9b8b498 diskpart: fix adding more as 4 partitions
    019edd7 examples: client: add port as argument for swupdate-client.py
    e41004b handlers: ubivol: add property always-remove
    1f4189c Regression: allow SW version comparisons as strings
    
    Signed-off-by: default avatarStefano Babic <sbabic@denx.de>
    26cc2024