Skip to content
  • Pierre-Jean Texier's avatar
    swupdate: bump to revision 9b2155e · 7e7afffb
    Pierre-Jean Texier authored and Stefano Babic's avatar Stefano Babic committed
    
    
    This includes the following changes:
    
    9b2155e Lua: add getroot function
    0ac47ed util: add function to retrieve root device
    829d11e IPC: extend to set accepted versions
    c46a180 Rename structure globals to parms
    7039df5 Restructure swupdate data
    0cfd653 Cleanup: type boolean in general structure
    8b4be00 Type dry_run as bool
    19d94fd Introduce an upper check for version to be installed
    0b34b6a raw handler: fix typo
    0968c76 state: Make save_state() write to STATE_KEY unconditionally
    87ed2e3 server_general: fix call of read_module_setting
    338dc8e Avoid re-opening and reading configuration file
    69f5d5a Lua: export preserve-attributes property
    506ad34 Core: Properly close socket after processing in networking thread
    e4eb7e5 doc: add talk at Liveembedded 2020
    aa91186 Make IPC more robust
    bf414d1 Config parser: Additional logging
    2d6555f Added software select to swupdate.cfg globals
    39483e6 Enable tracing for early start up code
    99e3f79 Simplify get_sw_versions
    063c066 state: Update code comments on persistent state handling
    05ce5c9 state: Optionally disable setting ustate marker
    ee47553 Fix install-if-higher behaviour if version is equal
    b11f494 Fix coverity #316445
    348cc4e Fix coverity #316444
    f6d7216 parser: add hook to partitions
    e1ae537 parser: follow the links
    5069ad4 parser: split find_node function
    6af3c38 editorconfig: added settings for *.cfg files
    e1915f1 bootloader: EBG: update transaction marker handling
    5df09dd bootloader: EBG: env_unset(STATE_KEY) ~ env_set(STATE_KEY, STATE_OK)
    0183fd7 IPC: allow to enable programmatically -o flag
    f77a762 Makefile: Run acceptance tests sequentially
    d525b3d channel_curl: Improve tracking of download progress
    1a22eca raw handler: Allow symlink traversal in blkprotect
    ea19f2f Replace int with enum in check_if_required
    d4a8bfe gservice: add missing dependency
    b1d1cd1 diskpart: fix warning in TRACE
    526e36b Sync update from file with CV
    a7f5568 Added missing copyright for strlcpy function
    6500f1e Add isc license text to Licenses
    f700061 lua: link lua_swupdate library
    4ebaad0 Create output directory for -o option
    91e9fea swupdate-client: use CV for synchronization
    58c5c5d Drop handling of exit status when install from file
    f5fc64b Drop unneeded wrapper save_state_string
    8b70ae5 Drop separate installation path for local file
    f65b3ea Fix warnings in mongoose code
    0fa7f9b Cleanup: drop dead code for Webserver API
    0c5b7d2 mongoose: updated to 6.18
    a18599a README: rework and drop obsolete parts
    08d95fa README: add license badge
    9123cf4 util: Whitespace fixes
    80408e0 util: Fix CID 314958
    a8794bf doc: improve roadmap
    d1494b7 doc: improve description how SWUpdate runs
    a1b8296 Make access to bootloader state exclusive also for GET_UPDATE_STATE
    27d4ad7 Execute subprocess IPC in separate thread
    1829ea7 Progress: set message status in download and progress mode
    0d23f72 Use valid JSON key format when sending progress info message
    70ce28a Add force flag in Makefile when creating symbolic link of shared IPC library
    4ca2f9d Remove unused compiler attributes from bootloader RAM environment implementation
    2aceb66 Type encrypted flag as bool
    
    Signed-off-by: default avatarPierre-Jean Texier <pierre-jean.texier@lafon.fr>
    7e7afffb