Commit 33750fbb authored by Stefano Babic's avatar Stefano Babic
Browse files

Convert to new override syntax



Use the convert-overrides.py to convert to new syntax
Signed-off-by: Stefano Babic's avatarStefano Babic <sbabic@denx.de>
parent 128364c3
......@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda
SRC_URI = "file://rcS.swupdate \
"
RPROVIDES_${PN} += "virtual/initscripts-swupdate"
RPROVIDES:${PN} += "virtual/initscripts-swupdate"
S = "${WORKDIR}"
......@@ -20,11 +20,11 @@ do_install () {
}
ALTERNATIVE_PRIORITY = "300"
ALTERNATIVE_${PN} = "init"
ALTERNATIVE:${PN} = "init"
ALTERNATIVE_LINK_NAME[init] = "${base_sbindir}/init"
ALTERNATIVE_PRIORITY[init] = "60"
PACKAGES = "${PN}"
FILES_${PN} = "/"
FILES:${PN} = "/"
CONFFILES_${PN} = ""
CONFFILES:${PN} = ""
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
FILES_${PN}-staticdev += "ubi-utils/libubi.a ${libdir}/*.a"
FILES:${PN}-staticdev += "ubi-utils/libubi.a ${libdir}/*.a"
do_install_append () {
do_install:append () {
install -d ${D}${includedir}/mtd/
install -d ${D}${libdir}/
install -m 0644 ${S}/include/libubi.h ${D}${includedir}
......
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
SRC_URI += "file://0001-Wrong-CRC-with-ASCII-CRC-for-large-files.patch"
......@@ -21,7 +21,7 @@ EXTRA_OEMAKE = 'PREFIX=${D}/usr BASELIB=${base_libdir} CROSS_COMPILE=${TARGET_PR
# recipe automatically - you will need to examine the Makefile yourself and ensure
# that the appropriate arguments are passed in.
FILES_${PN} = "${libdir} ${datadir}/lua"
FILES:${PN} = "${libdir} ${datadir}/lua"
do_configure () {
# Specify any needed configure commands here
......
......@@ -3,7 +3,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ab6706baf6d39a6b0fa2613a3b0831e7"
DEPENDS = "lua"
RDEPENDS_${PN} += "lua"
RDEPENDS:${PN} += "lua"
SRC_URI = "git://github.com/diegonehab/luasocket;protocol=https \
file://0001-fix-for-OE.patch \
......@@ -15,7 +15,7 @@ SRCREV = "652959890943c34d7180cae372339b91e62f0d7b"
S = "${WORKDIR}/git"
FILES_${PN} = "${libdir} ${datadir}/lua"
FILES:${PN} = "${libdir} ${datadir}/lua"
EXTRA_OEMAKE = 'DESTDIR=${D} BASELIB=${base_libdir} PREFIX=/usr CC="${CC}" LD="${CC}" MYLDFLAGS="${LDFLAGS}"'
......
......@@ -16,5 +16,5 @@ do_install() {
}
RDEPENDS_${PN} = "luafilesystem"
FILES_${PN} = "${libdir}/lua"
RDEPENDS:${PN} = "luafilesystem"
FILES:${PN} = "${libdir}/lua"
......@@ -26,7 +26,7 @@ PR = "r1"
S = "${WORKDIR}/git"
PACKAGES += "${PN}-examples"
FILES_${PN} = "${libdir} ${datadir}/lua"
FILES:${PN} = "${libdir} ${datadir}/lua"
inherit pkgconfig
......@@ -35,7 +35,7 @@ inherit pkgconfig
# NOTE: some of these dependencies may be optional, check the Makefile and/or upstream documentation
DEPENDS = "libx11 readline lua freetype libpng fontconfig"
DEPENDS = "lua freetype libpng fontconfig"
RDEPENDS_${PN} += "lua"
RDEPENDS:${PN} += "lua"
EXTRA_OEMAKE = 'PREFIX=${D}/usr BASELIB=${base_libdir} DISPLAY_DRIVER=rawfb CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} -fpic"'
......
......@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0-or-later;md5=fed5435554
inherit update-rc.d
DEPENDS += "swupdate lua luafilesystem"
RDEPENDS_${PN} += "swupdate-tools swupdate-lua"
RDEPENDS:${PN} += "swupdate-tools swupdate-lua"
SRC_URI = "git://github.com/sbabic/SWUpdateGUI.git;protocol=https \
file://rescuegui \
......@@ -21,7 +21,7 @@ SRCREV = "a52b3d3bc315eb1195fc6311c8170651a54d7893"
S = "${WORKDIR}/git"
FILES_${PN} = "/opt ${sysconfdir}"
FILES:${PN} = "/opt ${sysconfdir}"
do_configure () {
# Specify any needed configure commands here
......
......@@ -7,8 +7,8 @@ DEPENDS += "libconfig"
# https://sbabic.github.io/swupdate/licensing.html
# rst form: file://doc/source/licensing.rst
LICENSE = "GPLv2+ & LGPLv2+ & MIT"
LICENSE_${PN}-lua = "LGPLv2+"
LICENSE_${PN}-www = "MIT"
LICENSE:${PN}-lua = "LGPLv2+"
LICENSE:${PN}-www = "MIT"
LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
file://Licenses/lgpl-2.1.txt;md5=4fbd65380cdd255951079008b364516c \
file://Licenses/mit.txt;md5=838c366f69b72c5df05c96dff79b35f2 \
......@@ -41,43 +41,43 @@ PACKAGES =+ " \
${PN}-usb \
${PN}-www \
"
INSANE_SKIP_${PN}-lua = "dev-so"
INSANE_SKIP:${PN}-lua = "dev-so"
wwwdir ?= "/www"
# tools is now an empty meta package for backward compatibility
ALLOW_EMPTY_${PN}-tools = "1"
ALLOW_EMPTY:${PN}-tools = "1"
FILES_${PN}-client = "${bindir}/swupdate-client"
FILES_${PN}-lua += "${libdir}/lua/"
FILES_${PN}-progress = " \
FILES:${PN}-client = "${bindir}/swupdate-client"
FILES:${PN}-lua += "${libdir}/lua/"
FILES:${PN}-progress = " \
${bindir}/swupdate-progress \
${systemd_system_unitdir}/swupdate-progress.service \
${libdir}/swupdate/conf.d/90-start-progress \
"
FILES_${PN}-usb = " \
FILES:${PN}-usb = " \
${sysconfdir}/udev/rules.d/swupdate-usb.rules \
${systemd_system_unitdir}/swupdate-usb@.service \
"
FILES_${PN}-tools-hawkbit = " \
FILES:${PN}-tools-hawkbit = " \
${bindir}/swupdate-hawkbitcfg \
${bindir}/swupdate-sendtohawkbit \
"
FILES_${PN} += " \
FILES:${PN} += " \
${libdir}/tmpfiles.d \
${libdir}/swupdate/* \
${systemd_system_unitdir}/swupdate.socket \
${systemd_system_unitdir}/swupdate.service \
${sysconfdir}/init.d/* \
"
FILES_${PN}-www = " \
FILES:${PN}-www = " \
${libdir}/swupdate/conf.d/*mongoose* \
${wwwdir}/* \
"
RDEPENDS_${PN}-usb += "${PN}-client"
RDEPENDS:${PN}-usb += "${PN}-client"
# The tools package is deprecated, it is an empty meta package for backward compatibility
RDEPENDS_${PN}-tools += "${PN}-client ${PN}-progress ${PN}-tools-hawkbit \
RDEPENDS:${PN}-tools += "${PN}-client ${PN}-progress ${PN}-tools-hawkbit \
${@bb.utils.contains('DISTRO_FEATURES','systemd','${PN}-usb','',d)} \
"
......@@ -266,6 +266,6 @@ INITSCRIPT_NAME = "swupdate"
INITSCRIPT_PARAMS = "defaults 70"
SYSTEMD_PACKAGES = "${PN} ${PN}-progress ${PN}-usb"
SYSTEMD_SERVICE_${PN} = "swupdate.service swupdate.socket"
SYSTEMD_SERVICE_${PN}-progress = "swupdate-progress.service"
SYSTEMD_SERVICE_${PN}-usb = "swupdate-usb@.service"
SYSTEMD_SERVICE:${PN} = "swupdate.service swupdate.socket"
SYSTEMD_SERVICE:${PN}-progress = "swupdate-progress.service"
SYSTEMD_SERVICE:${PN}-usb = "swupdate-usb@.service"
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment