1. 16 Apr, 2021 1 commit
  2. 12 Apr, 2021 13 commits
  3. 05 Apr, 2021 2 commits
  4. 04 Apr, 2021 2 commits
  5. 01 Apr, 2021 1 commit
  6. 31 Mar, 2021 7 commits
  7. 29 Mar, 2021 2 commits
  8. 28 Mar, 2021 3 commits
  9. 27 Mar, 2021 9 commits
    • Tom Rini's avatar
      Merge branch '2021-03-27-master-imports' · 31637e0b
      Tom Rini authored
      - Rework the deprecation warnings to be consistently phrased.
      - Add in a warning for DM_I2C, for a year from next release.
      - Fix Azure builds of Windows host tools.
      31637e0b
    • Tom Rini's avatar
      Azure: Use "pacman -Sy" to install the toolchain · 94d66d8b
      Tom Rini authored
      
      
      We now see an error such as:
      warning: database file for 'ucrt64' does not exist (use '-Sy' to download)
      error: failed to prepare transaction (could not find database)
      
      So use -Sy as suggested.
      Signed-off-by: Tom Rini's avatarTom Rini <trini@konsulko.com>
      Reviewed-by: Bin Meng's avatarBin Meng <bmeng.cn@gmail.com>
      94d66d8b
    • Simon Glass's avatar
      dm: i2c: Add a migration method for I2C · 65c8cdc7
      Simon Glass authored and Tom Rini's avatar Tom Rini committed
      
      
      This probably should have been done a while back since it is a core
      system. Add a migration deadline of later this year, to catch the
      stragglers.
      Signed-off-by: Simon Glass's avatarSimon Glass <sjg@chromium.org>
      65c8cdc7
    • Simon Glass's avatar
      Makefile: Drop the old SPI flash migration message · 782dac5b
      Simon Glass authored and Tom Rini's avatar Tom Rini committed
      
      
      This message does not seem to make sense. It may be out of date. Drop it.
      Signed-off-by: Simon Glass's avatarSimon Glass <sjg@chromium.org>
      782dac5b
    • Simon Glass's avatar
      Makefile: Use common code for DM_ETH deprecation warning · 8cd1874f
      Simon Glass authored and Tom Rini's avatar Tom Rini committed
      
      
      Update the CONFIG_DM_ETH check to use the 'deprecated' function.
      
      Tested with snow
      
      Old message:
      
      ===================== WARNING ======================
      This board does not use CONFIG_DM_ETH (Driver Model
      for Ethernet drivers). Please update the board to use
      CONFIG_DM_ETH before the v2020.07 release. Failure to
      update by the deadline may result in board removal.
      See doc/driver-model/migration.rst for more info.
      ====================================================
      
      New message:
      
      ===================== WARNING ======================
      This board does not use CONFIG_DM_ETH (Driver Model
      for Ethernet drivers). Please update the board to use
      CONFIG_DM_ETH before the v2020.07 release. Failure to
      update by the deadline may result in board removal.
      See doc/driver-model/migration.rst for more info.
      ====================================================
      Signed-off-by: Simon Glass's avatarSimon Glass <sjg@chromium.org>
      8cd1874f
    • Simon Glass's avatar
      Makefile: Use common code for WDT deprecation warning · 78b4a564
      Simon Glass authored and Tom Rini's avatar Tom Rini committed
      
      
      Update the CONFIG_WDT check to use the 'deprecated' function.
      
      Tested with kmcent2
      
      Old message:
      
      ===================== WARNING ======================
      This board does not use CONFIG_WDT (DM watchdog support).
      Please update the board to use CONFIG_WDT before the
      v2019.10 release.
      Failure to update by the deadline may result in board removal.
      See doc/driver-model/migration.rst for more info.
      ====================================================
      
      New message:
      
      ===================== WARNING ======================
      This board does not use CONFIG_WDT (Driver Model
      for DM watchdog). Please update the board to use
      CONFIG_WDT before the v2019.10 release. Failure to
      update by the deadline may result in board removal.
      See doc/driver-model/migration.rst for more info.
      ====================================================
      Signed-off-by: Simon Glass's avatarSimon Glass <sjg@chromium.org>
      78b4a564
    • Simon Glass's avatar
      Makefile: Use common code for SPI_FLASH deprecation warning · ec384f9f
      Simon Glass authored and Tom Rini's avatar Tom Rini committed
      
      
      Update the CONFIG_DM_SPI_FLASH check to use the 'deprecated' function.
      
      Tested with vinco
      
      Old message:
      
      ===================== WARNING ======================
      This board does not use CONFIG_DM_SPI_FLASH. Please update
      the board to use CONFIG_SPI_FLASH before the v2019.07 release.
      Failure to update by the deadline may result in board removal.
      See doc/driver-model/migration.rst for more info.
      ====================================================
      
      New message:
      
      ===================== WARNING ======================
      This board does not use CONFIG_DM_SPI_FLASH (Driver Model
      for SPI flash). Please update the board to use
      CONFIG_DM_SPI_FLASH before the v2019.07 release. Failure to
      update by the deadline may result in board removal.
      See doc/driver-model/migration.rst for more info.
      ====================================================
      Signed-off-by: Simon Glass's avatarSimon Glass <sjg@chromium.org>
      ec384f9f
    • Simon Glass's avatar
      Makefile: Use common code for DM_VIDEO deprecation warning · d13aee07
      Simon Glass authored and Tom Rini's avatar Tom Rini committed
      
      
      Update the CONFIG_DM_VIDEO check to use the 'deprecated' function.
      
      Tested with pxm2
      
      Old message:
      
      ===================== WARNING ======================
      This board does not use CONFIG_DM_VIDEO Please update
      the board to use CONFIG_DM_VIDEO before the v2019.07 release.
      Failure to update by the deadline may result in board removal.
      See doc/driver-model/migration.rst for more info.
      ====================================================
      
      New message:
      
      ===================== WARNING ======================
      This board does not use CONFIG_DM_VIDEO (Driver Model
      for video). Please update the board to use
      CONFIG_DM_VIDEO before the v2019.07 release. Failure to
      update by the deadline may result in board removal.
      See doc/driver-model/migration.rst for more info.
      ==================================================
      Signed-off-by: Simon Glass's avatarSimon Glass <sjg@chromium.org>
      d13aee07
    • Simon Glass's avatar
      Makefile: Use common code for PCI deprecation warning · 39e526a8
      Simon Glass authored and Tom Rini's avatar Tom Rini committed
      
      
      Update the CONFIG_DM_PCI check to use the 'deprecated' function.
      
      Tested with MPC8349ITX
      
      Old message:
      
      ===================== WARNING ======================
      This board does not use CONFIG_DM_PCI Please update
      the board to use CONFIG_DM_PCI before the v2019.07 release.
      Failure to update by the deadline may result in board removal.
      See doc/driver-model/migration.rst for more info.
      ====================================================
      
      New message:
      
      ===================== WARNING ======================
      This board does not use CONFIG_DM_PCI (Driver Model
      for PCI). Please update the board to use
      CONFIG_DM_PCI before the v2019.07 release. Failure to
      update by the deadline may result in board removal.
      See doc/driver-model/migration.rst for more info.
      ====================================================
      Signed-off-by: Simon Glass's avatarSimon Glass <sjg@chromium.org>
      39e526a8